mqTranslate no compatible con wordpress 4.3

mqtranslate error de incompatibilidad con wordpress 4.3

Si tienes un wordpress multiidioma en el que utilizas el plugin mqTranslate y actualizas a la versión 4.3 de wordpress es posible que te encuentres con un mensaje de error en tu zona de administración que te dice algo así como  que mqTranslate se deshabilita a si mismo para evitar incompatibilidades porque no está preparado para esa versión de wordpress.

The mqTranslate Editor has disabled itself because it hasn\’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. To remove this message permanently, please update mqTranslate to the corresponding version.

 

Yo mismo me he vuelto un poco tarumba para dar con una solución para esto y acabé encontrandola, tan sencilla como:

  1. Acceder a Apariencia > Plugins
  2. En el plugin mqTranslate clic en Editar
  3. En el archivo mqtranslate.php buscar la línea
    define(‘QT_MAX_SUPPORTED_WP_MAJOR_VERSION’, ‘4.0’);
  4. Cambiar el ‘4.0’ por get_bloginfo(‘version’), de forma que quede así
    define(‘QT_MAX_SUPPORTED_WP_MAJOR_VERSION’, get_bloginfo(‘version’));

Listo, le hemos dicho al mqTranslate que acepte como versión máxima la versión actual de nuestro wordpress. Por supuesto esto es un poco ñapa pero nos servirá hasta que saquen una actualización en condiciones que solucione el problema o migremos a otro plugin para multiidioma, personalmente recomiendo el polylang.

¡Compartir mola!Share on Facebook0Share on Google+0Share on LinkedIn0Tweet about this on TwitterBuffer this pageEmail this to someone

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *